CoffeeHUD PT4 Outage

15 replies [Last post]
serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013

Update: There is a PT update 4.11.2 that fixes the CoffeeHUD outage. We recommend that all CoffeeHUD customers update their PokerTracker to the latest version.

Synopsis: CoffeeHUD is currently not functioning in PT4. The developers at PokerTracker are aware of the issue and are working hard to make a fix that will set things back to normal. As of this writing, we do not have an ETA on when the fix will be ready. Right now, the best thing to do seems to be simply to wait for the fix. We are monitoring the situation, and will update this post with new information as it becomes available.

Detail: We can't say with definite certainty, but from information gathered from forum posts and e-mails from customers, it seems that the problem was caused by the update to PokerTracker 4.11.1. It looks like there was an older bug in PT4 that was affecting some customers. The 4.11.1 update was intended to fix that older bug, and inadvertently caused CoffeeHUD and many other custom HUDs and stats to break. This was not the intended effect of the update, and since then PokerTracker developers have been working hard to fix these issues.

At first, only PT4 users who had upgraded to 4.11.1 were affected. However, as of right now, all users, even those that did not upgrade to 4.11 or 4.11.1, are unable to use their CoffeeHUD. While trying to fix this issue, PokerTracker devs, with our permission, made an update to CoffeeHUD that bumped the CoffeeHUD version number from 2.0.1 to 2.0.2. As of right now, this update does not appear to have fixed the problems, and instead now even users who are on older versions of PT4 are unable to use CoffeeHUD either. PokerTracker are still doing their best to fix the errors.

What To Do: We realize that, for a lot of you, this is messing with your grinds. We are watching the situation as best we can. As new information becomes available, we'll be editing this post to reflect that. Right now, however, there is nothing to do other than wait.

Most likely, updates to either PT4 or CoffeeHUD (or maybe both) will need to be issued to fix this problem. For CoffeeHUD, this is not a problem, because CoffeeHUD updates are downloaded and installed automatically when needed. For PT4 updates, users can either choose to install all updates until the problem is corrected, or they can choose to not install any updates and instead monitor the situation themselves to decide when to install or not install the updates. For simplicity's sake, we recommend that users take care to keep their PT4 up-to-date.

Users that instead decide they want to be selective about whether or not to apply PT4 updates are advised to monitor the situation. As I've written above, we will be updating this post with new information. Users can also monitor this situation on the PokerTracker forums. There is a forum topic on PT's forums that provides some extra information. Also, their forums have an Atom feed that news feed fans can subscribe to in order to watch for new posts in the PT forums.

Thank you for your patience. If there is anything we can do to help PokerTracker get a fix up, we will certainly do that as fast as we can. In the mean time, we want to remind CoffeeHUD customers that this error is not malicious in nature. It was an accident, and it would have been prevented if the PT developers had foreseen it.

Mayo's picture
Mayo
Offline
Veteran
Joined: Mar 12 2014
Thanks for the message. Now

Thanks for the message. Now we know at least that we can do nothing more but wait. Hope they will fix it soon :-)

chaosad's picture
chaosad
Offline
Veteran
Joined: Oct 24 2010
Isnt it possible to release

Isnt it possible to release the latest stable version of the HUD again, so many users with PT 4.10.9 could use the HUD without any problems?

 

RyPac13's picture
RyPac13
Offline
Site Administrator
Joined: Oct 21 2008
If there is no solution in

If there is no solution in the next 8 hours or so, we will look at other options.

The problem isn't in the CoffeeHUD, it's in PokerTracker, PokerTracker says they should be able to patch this today.

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
Hi chaosad, Yes, that is

Hi chaosad,

Yes, that is possible. However, such an approach presents three additional problems:

•As PokerTracker continues to try to fix this problem, introducing an alternative CoffeeHUD profile could interfere with their efforts by creating additional name conflicts.

•We don't know what this will do to customers who are already past 4.10.9. It might help 4.10.9 users but hurt 4.11.x users.

•CoffeeHUD activations are entered by hand one customer at a time, and we currently have hundreds of registered CoffeeHUD customers. It would take many hours for us to just register everyone for an older CoffeeHUD version.

The upside to all of that is that, if everything else fails, we do have our own fallback: We can ask all CoffeeHUD customers to downgrade to an older PT4 release, and then downgrade (or add as an alternative) the older version of CoffeeHUD. We might even be able to get PokerTracker to move over the registrations for us in bulk, or write a form submitting script to register users automatically, so we don't have to spend the many hours it would take to move everyone by hand. However, that's more of a "worst case scenario" type of contigency. The best thing to do is to give the PokerTracker folks the time that they need to develop a proper, correct fix.

Mepslol's picture
Mepslol
Offline
New User
Joined: Apr 15 2014
Im just glad to see you

Im just glad to see you working on it and responding that fast.

Thats the support that i wish for <3

teddybloat's picture
teddybloat
Offline
Elite
Joined: Aug 1 2013
my coffee HUD is working fine

my coffee HUD is working fine atm

i did have the error problems but currently am running PT4 v4.11.1 and CoffeeHUD v2.0.2

one thing i did have to do was to manually remove the old coffeeHUD profile from the active profile definitons window in HUD OPTIONS,  and select the new one.

hope this info is useful

 

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
Very useful, thank you. I'm

Very useful, thank you. I'm gonna test this with my own HUD, and if things are looking good, I'll add the info to the news post.

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
No luck, unfortunately. Still

No luck, unfortunately. Still have the unknown token issue.

vzhong's picture
vzhong
Offline
New User
Joined: Feb 18 2009
Fix it in PT4

"Until the new version is available with the fix, you can resolve the issue on your own by going into Configure -> Statistics. View Stats and filter for 'Show Custom Stats'. Scroll through the custom stats and any stat that is referencing a column with uppercase characters, change the uppercase characters to lowercase and save. (Repeat for all stats)"

Fixed my HUD following this tip.

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
vzhong, that would work for

vzhong, that would work for custom stats written by end-users, but it won't work for stats that are protected by PT4's built-in add-on mechanism, which is what CoffeeHUD and its stats falls under. PokerTracker did replace all the column references with lower-case ones for us when they made the 2.0.2 update for CoffeeHUD, but that hasn't been enough to fix the problems.

Thanks for the suggestion, though. Any users who have homebrew custom stats they are having trouble with can still follow your solution and it should work for them.

chaosad's picture
chaosad
Offline
Veteran
Joined: Oct 24 2010
still no fix for 4.10.9?

still no fix for 4.10.9?

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
Hi chaosad,My understanding

Hi chaosad,

My understanding is that the 2.0.2 version of the CoffeeHUD will not load for PT4 versions older than 4.11.1. I think the 2.0.1 version of CoffeeHUD will work with both newer and older versions of PT4. However, I am trepidatious about replacing 2.0.2 with 2.0.1 because I am not sure how well PT4's add-in management mechanisms will handle that kind of a downgrade.

Basically, this is how I understand PT4 versioning right now with regards to CoffeeHUD:

•Pre-4.11.1 will load and work with 2.0.1 but it refuses to load 2.0.2

•4.11.1 will load both 2.0.1 and 2.0.2 but will not work with either of them ("unknown token" errors)

•4.11.2 will load and work with both 2.0.1 and 2.0.2

We can replace 2.0.2 with 2.0.1 and if my understanding above is correct, 2.0.1 should work for both users who have upgraded to the 4.11.x track and for users who have stayed with 4.10.9 and older releases. I don't think it is appropriate for us to force such a downgrade arbitrarily because of the possibility such a downgrade might expose more PT4 bugs and subject our customers to yet another downtime. Our recommended solution is instead that all customers upgrade to 4.11.2. However, that possibility is nonetheless something that we must consider if there is a compelling argument to be made against upgrading to 4.11.2. We are very much open to feedback and suggestions.

I am interested in your and other customers' opinion on this issue. Are you very strongly opposed to upgrading to 4.11.2?

Dipl.Komp.'s picture
Dipl.Komp.
Offline
Elite
Joined: Oct 28 2012
PT 4.11.2 fixed the bug for

PT 4.11.2 fixed the bug for me.

tata_bogat's picture
tata_bogat
Offline
New User
Joined: Nov 29 2012
Hello ,  Today i updated to

Hello , 

Today i updated to the latest PT4  and again with the problems , a lot of the stats in coffe hud are not updating.

I dont like criticising nobody , but why are you guys not being proactive and give us the choice:

1)Either you wait for them to fix it , and be their guineea pig with all their problems.

2)Or you downgrade to a secure version and you make coffehud to work on that version.

 

I dont understand your attitude , lets wait and someone else fix the problem ( the poker tracker team), take responsability , its your product .

It would cost 50-100$maximum  to pay someone to do that for you ( the entering mannually every license) but you said that you have hundreds of licenses to put , that means that hundreds of customers are loosing money because you dont do that. much more than 50-100 dolars. 

if they lost only 50$ each because of theese problems and i think is more , and you have only 200 customers that means that people lost more than 10.000$ because you dindt want to pay 50-100 to do the work.

 

Hope you choose to  do something now,

Have a nice day ,

Bogdan

 

 

serge's picture
serge
Offline
Site Staff
Joined: Jul 26 2013
Hi Bogdan, Sorry for the late

Hi Bogdan,

Sorry for the late response. I didn't notice your post until now, as I've stopped monitoring this thread after no one was posting here anymore.

Most of the problems have been fixed, and for most players everything has been working fine for more than a week now. There are a few players that still have one-off errors, and I'm working one on one with them now to try to resolve those.

It doesn't make sense for us to move everyone that is on CoffeeHUD 2.0.2 back to CoffeeHUD 2.0.1 if CoffeeHUD 2.0.2 is working correctly. The only difference between 2.0.1 and 2.0.2 is that some columns that had upper-case letters in their name were changed to use all lower-case letters. Functionally, there is no difference between the two versions. However, in the past we've seen how forcing an upgrade can trigger bugs in PT4 and render CoffeeHUD unusable. I can only assume that the same may be true in a downgrade as well. Thus, it would be very irresponsible and bad service on our part to just move everyone from 2.0.2 and possibly expose them to more bugs when everything is working fine for them already just because some players are still having errors. A better approach would be to instead move just those players who want it to 2.0.1 and leave everyone else alone. You can see, in my other thread on this topic, where I make just such an offer:

The current mainline version of CoffeeHUD, 2.0.2, will not work with PT 4.10.9 or older versions. Current CoffeeHUD 2.0.2 users who need to get a copy of CoffeeHUD 2.0.1 for use with 4.10.9 or older releases should e-mail me their PT4 registration e-mail and 6-digit code (in PT4, go to Help and then About to find this info), and I will activate you for 2.0.1.

We don't recommend a direct downgrade to 4.10.9 unless the player has a manual backup of his / her PT4 database from before he / she began the upgrade to 4.11.x. When upgrading from 4.10.9 to 4.11.x, the database is altered in such a way that makes it incompatible with 4.10.9. When PT releases an update like that, the update process offers the user the choice to automatically back everything up prior to starting the update. However, with the earliest releases in the 4.11.x series (I believe this applied to the original 4.11 and 4.11.1), that backup procedure was bugged and created a backup that was worthless for downgrading purposes. Thus, unless the player had made a manual backup before starting the update, it is impossible to go back to 4.10.9 and still use the same database.

There is, of course, the "hard way": delete your database and re-import all of your hands from scratch as if you just installed PT4 for the first time. If you do that, then it is possible to go back to 4.10.9 without a manual backup. For this reason, I've been giving players access to 2.0.1 CoffeeHUD (the version of CoffeeHUD that was working fine with 4.10.9, before all this trouble started) whenever they've asked for it. Sometimes everything is back to working normally that way, and sometimes it's not. Generally speaking, the few players that are still having problems are having problems that are more complicated and a simple version up or version down in either PT4 or CoffeeHUD is just not enough to fix those problems.

Why don't you send me an e-mail with a little more details on the errors you have now, and I'll see about how to fix it?